Support Portal Issues
Incident Report for blubolt
Resolved
The support help desk is now up and running; and we are able to receive and view support requests.
Posted 8 months ago. Sep 26, 2018 - 10:17 BST
Identified
Our Zendesk support portal is currently unreachable and we are unable to view support requests. Zendesk have acknowledged these issues.

We remain available on our support line: 01225580037 for any urgent issues.

We will keep you updated.
Posted 8 months ago. Sep 26, 2018 - 09:20 BST
This incident affected: Other services (Support).