bluCommerce Pay availability
Incident Report for blubolt
Resolved
This incident has been resolved.
Posted Jan 25, 2020 - 01:57 GMT
Update
We have mitigated the impact of the AWS incident as much as possible at this time, however we remain unable to provision sufficient capacity to cope with payment demand as the bluCommerce Pay system makes use of AWS services which rely on Route 53 for DNS during the provisioning process. AWS are continuing to investigate with status updates being provided at https://status.aws.amazon.com/
Posted Jan 24, 2020 - 22:28 GMT
Identified
Our ongoing monitoring is showing that our mitigation steps have not achieved normal levels of availability. We are continuing to assess what further options are available to us at this time.
Posted Jan 24, 2020 - 21:45 GMT
Monitoring
We have taken mitigation steps which have restored bluCommerce Pay service with card payments now fully available in bluCommerce site checkouts. We will continue to monitor the service and the root cause AWS incident and provide updates as necessary.
Posted Jan 24, 2020 - 21:31 GMT
Identified
We have identified the root cause of the issue to be AWS-wide delays in propagation of Route 53 DNS edits. Please see https://status.aws.amazon.com/ for the current status of the AWS incident. This is impacting the bluCommerce Pay dynamic security and firewall protection systems. We are currently working to mitigate the impact of the AWS incident in order to restore service.
Posted Jan 24, 2020 - 21:23 GMT
Update
We are continuing to investigate the cause of the availability issues with the bluCommerce Pay system. Alternative payment methods including PayPal, Amazon Payments and Klarna are not affected by this issue and remain available.
Posted Jan 24, 2020 - 21:10 GMT
Investigating
We are currently investigating reports from our monitoring system relating to availability of the bluCommerce Pay system. We will provide further updates here.
Posted Jan 24, 2020 - 20:58 GMT
This incident affected: Websites (Checkout & Cart).