Email Service Disruption
Incident Report for blubolt
Resolved
This incident has been resolved.
Posted May 14, 2020 - 20:55 BST
Identified
The cause of the service disruption has been identified and we are currently investigating solutions.
Posted May 14, 2020 - 15:31 BST
Investigating
We are currently investigating a disruption with our email service.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 15 minutes.
Posted May 14, 2020 - 15:20 BST